Estou utilizando a última versão do Vindula e já é a terceira vez que o banco de dados para de funcionar e corrompe o banco do vindula.

Alguém mais já teve esse problema? Conseguiram alguma correção definitiva?

O produto é muito bom, mas esse tipo de falha acaba inviabilizando a utilização.

perguntou 04 Out '13, 16:44

duduowns's gravatar image

duduowns
405171823
aceitar classificação: 37%


12próxima »

Eduardo,

Você esta utilizando a versão antiga da maquina virtual, a versão mais recente é a Vindula-2.0.2-1LTS.

Que tem as seguintes versões:

alt text

Seu problema com o banco de dados não é a aplicação que está corrompendo os dados, mas sim um problema no mysql server, durante a atualização da versão 5.1 para 5.5, onde o mesmo não inicia após a atualização.

A versão anterior da maquina virtual, conta com mysql-server 5.1, e requer um procedimento cuidadoso de migração para mysql server 5.5 ou superior, pois existem incompatibilidades entres as versões, podendo consultar as notas para atualização na documentação oficial do MySQL.

Assim recomendo que não deixe a opção de atualizações automáticas do Ubuntu ativado, nem efetue atualização do mysql server, antes de efetuar um dump completo do banco.

Att,

link fixo

respondida 18 Out '13, 14:21

mauriciosousa's gravatar image

mauriciosousa ♦♦
1.2k210
aceitar classificação: 72%

Olá Eduardo,

Pode nos dar mais detalhes sobre o problema:

  • Está utilizando a maquina virtual? qual versão?
  • Que procedimento realizava quando ocorreu o erro?
  • Efetuou alguma atualização no sistema operacional?
  • Qual mensagem de erro que diz do corrompimento do banco de dados?

Att,

link fixo

respondida 07 Out '13, 18:54

mauriciosousa's gravatar image

mauriciosousa ♦♦
1.2k210
aceitar classificação: 72%

Bom dia Mauricio.

Estou usando a máquina virtual do próprio Vindula.

Versão do Vindula Vindula 2.0a3 Versões Gerais Plone 4.2.0.1 (4206) CMF 2.2.6 Zope 2.13.15 Python 2.7.3 (default, Aug 1 2012, 05:16:07) [GCC 4.6.3] PIL 1.7.8 (Pillow)

Segundo o log de atualização, aparentemente o sistema foi atualizado no dia 2013-07-20.

Segue também outras informações: Linux vindula.intranet 3.2.0-49-generic #75-Ubuntu SMP Tue Jun 18 17:40:13 UTC 2013 i686 i686 i386 GNU/Linux

link fixo

respondida 08 Out '13, 10:05

duduowns's gravatar image

duduowns
405171823
aceitar classificação: 37%

Vale ressaltar aqui a solução paliativa:

Parar o processo do banco de dados: service mysql stop

Mover os arquivos ib_logfile para outro diretório: mv /var/lib/mysql/ib_logile /tmp

Iniciar novamente o serviço: service mysqlstart

Assim o banco sobre normalmente e é possível utilizar a intranet.

Estou estudando a solução definitiva, mas ainda não cheguei em um cenário final.

link fixo

respondida 14 Out '13, 11:41

duduowns's gravatar image

duduowns
405171823
aceitar classificação: 37%

E nesse caso, consigo simplesmente baixar a máquina nova e exportar os dados de uma base pra outra?

link fixo

respondida 11 Nov '13, 17:11

duduowns's gravatar image

duduowns
405171823
aceitar classificação: 37%

Aqui tbm estou com esse problema, pelo menos umas 3 vezes na semana tenho que usar o procedimento de apagar os arquivos ib_logile para que a intranet fique acessível,existe algum método definitivo para solucionar isso?

link fixo

respondida 12 Nov '13, 08:44

dougsky's gravatar image

dougsky
251161722
aceitar classificação: 29%

Opa,

Esse erro ai é de configuração do MySQL. É importante que você instale o Vindula via tar.gz e não utilize a VM para produção.

Vamos lançar no fim do ano, uma versão do Vindula em VM para produção, toda tunada, mas mesmo assim, existem as questões de disco, acesso entre outras coisas.

Novamente, via tar.gz é a melhor solução.

(12 Nov '13, 10:56) fabiorizzo ♦♦

Você também pode fazer um cron com os comandos e rodar a noite como rotina de manutenção.

(12 Nov '13, 10:58) fabiorizzo ♦♦

Certo Fábio,mas e possível instalar via tar.gz e migrar o conteúdo que já tenho na vm ?

(12 Nov '13, 14:10) dougsky

Doug, consegues confirmar a versão do teu Vindula pra gente saber se a origem do problema é a mesma (atualização do MySQL)?

Abraço!

link fixo

respondida 12 Nov '13, 08:48

duduowns's gravatar image

duduowns
405171823
aceitar classificação: 37%

Segue-se a versão

alt text

link fixo

respondida 12 Nov '13, 10:38

dougsky's gravatar image

dougsky
251161722
aceitar classificação: 29%

Fiz a instalação via tar.gz,mas na Vm ja tenho toda personalização pronta,tem como exportar para a maquina fisica ? help....

link fixo

respondida 13 Nov '13, 08:39

dougsky's gravatar image

dougsky
251161722
aceitar classificação: 29%

Pelo o que eu vi é a mesma versão que estou utilizando. Você chegou a atualizar o Ubuntu e por consequência o MySQL?

link fixo

respondida 13 Nov '13, 09:31

duduowns's gravatar image

duduowns
405171823
aceitar classificação: 37%

Sua resposta
alternar pré visualização

Acompanhar esta pergunta

Por Email:

Uma vez que você entrar você será que capaz de assinar qualquer atualização

Por RSS:

Respostas

Respostas e Comentários

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Título")
  • image?![alt text](/path/img.jpg "Título")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags da pergunta:

×12
×3
×2

pergunta: 04 Out '13, 16:44

pergunta foi visualizada: 4,346 vezes

útima atualização: 13 Nov '13, 10:03