Fiz a integração dos usuarios do AD ao vindula. Os usuarios conseguem fazer o login normalmente, porem quando vou acessar as permissões de usuarios aparece um erro. Ao habilitar a opção User_Enumeration, que é necessaria para que os usuarios façam login alt text Ao acessar as permissões dos usuarios alt text Aparece o seguinte erro abaixo:

Desculpe, mas parece haver um erro… Aqui está a mensagem de erro completa:

Visualizar traceback como texto

Traceback (innermost last):

Module ZPublisher.Publish, line 126, in publish Module ZPublisher.mapply, line 77, in mapply Module ZPublisher.Publish, line 46, in call_object Module grokcore.view.components, line 100, in call Module grokcore.view.components, line 104, in _render_template Module five.grok.components, line 134, in render Module zope.pagetemplate.pagetemplate, line 113, in pt_render Module zope.tal.talinterpreter, line 271, in call Module zope.tal.talinterpreter, line 343, in interpret Module zope.tal.talinterpreter, line 583, in do_setLocal_tal Module zope.tales.tales, line 696, in evaluate URL: /opt/vindula/app/vindula/src/vindula.controlpanel/vindula/controlpanel/browser/views_templates/showallrolesusersview.pt Line 50, Column 1 Expression: <pathexpr standard:u'view="" __call__'=""> Names: {'args': (), 'container': <plonesite at="" vindula="">, 'context': <plonesite at="" vindula="">, 'default': <object object="" at="" 0xb76e5698="">, 'here': <plonesite at="" vindula="">, 'loop': {}, 'nothing': None, 'options': {}, 'repeat': <products.pagetemplates.expressions.safemapping object="" at="" 0xb0467bbc="">, 'request': <httprequest, url="&lt;a" href="http://192.168.10.20/usergroup-userprefs-all&gt;,">http://192.168.10.20/usergroup-userprefs-all>, 'root': <application at="">, 'static': None, 'template': <products.five.browser.pagetemplatefile.viewpagetemplatefile object="" at="" 0xe5c720c="">, 'traverse_subpath': [], 'user': <ploneuser 'administrador'="">, 'view': <vindula.controlpanel.browser.views.showallrolesusersview object="" at="" 0xb042a02c="">, 'views': <products.five.browser.pagetemplatefile.viewmapper object="" at="" 0xb0455d0c="">} Module zope.tales.expressions, line 217, in call Module Products.PageTemplates.Expressions, line 155, in _eval Module Products.PageTemplates.Expressions, line 117, in render Module plone.app.controlpanel.usergroups, line 193, in call Module plone.app.controlpanel.usergroups, line 214, in doSearch Module Products.PluggableAuthService.PluggableAuthService, line 216, in getUserById Module Products.PluggableAuthService.PluggableAuthService, line 734, in _findUser Module Products.PluggableAuthService.PluggableAuthService, line 667, in _getGroupsForPrincipal Module Products.PluggableAuthService.plugins.ZODBGroupManager, line 142, in getGroupsForPrincipal UnicodeDecodeError: 'utf8' codec can't decode byte 0xe7 in position 10: invalid continuation byte

0

perguntou 15 Jul '13, 10:33

ewerton_marques's gravatar image

ewerton_marques
768810
aceitar classificação: 33%


Boa Tarde,

Era exatamente isso. Fiz uma pesquisa em todos usuarios do AD e identifiquei alguns usuarios com caracteres especiais. Foi removido os acentos e agora esta funcionando normalmente.

Agradeço a ajuda.

Att. Ewerton Marques

link fixo

respondida 24 Jul '13, 12:27

ewerton_marques's gravatar image

ewerton_marques
768810
aceitar classificação: 33%

Boa tarde ewerton_marques!

Ewerton o erro indicado pelo o LOG mostra que dentro do seu AD existe algum usuário(s) com carácter especial, caso seja isso edite o(s) usuário(s) e tente fazer novamente o procedimento do interligação com o AD.

Espero ter lhe ajudado XD!

Att,

Guilherme Gomides

link fixo

respondida 18 Jul '13, 13:19

guigpg's gravatar image

guigpg
73914
aceitar classificação: 46%

Sua resposta
alternar pré visualização

Acompanhar esta pergunta

Por Email:

Uma vez que você entrar você será que capaz de assinar qualquer atualização

Por RSS:

Respostas

Respostas e Comentários

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Título")
  • image?![alt text](/path/img.jpg "Título")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags da pergunta:

×23
×13
×1
×1

pergunta: 15 Jul '13, 10:33

pergunta foi visualizada: 2,205 vezes

útima atualização: 24 Jul '13, 12:27